WooPayments 7.9.1

Does WooPayments work with WordPress 6.5.5 and PHP 8.1.12? A smoke test was performed on .

Summary

Errors
The plugin could not be activated (it requires another plugin to be installed, but plugin dependencies are not supported by this site)
No PHP errors, warnings or notices
Performance

No data available.

Environment
WordPress version6.5.5
PHP version8.1.12
MySQL version10.6.10
PHP memory limit512M
Plugin Info
Last updated
Active installs 700,000+
WordPress.org page https://wordpress.org/plugins/woocommerce-payments/
Badges

WordPress compatibility badge PHP compatibility badge

Get badge code

Pages

No data available.

Benchmark

No benchmark data available.

Code Statistics

Note: Third-party libraries and minified JS/CSS files are excluded from these statistics where possible, so the numbers you see here may be lower than those reported by other tools.

PHP
Language % Lines of code Comment lines Files
PHP93.3%44,33225,824380
Markdown3.4%1,629040
SVG2.2%1,062056
CSS0.8%39965
JavaScript0.1%71111
JSON0.1%3201
Total 47,525 25,841 483

PHP Code Analysis | More results »

Lines of code 39,032
Total complexity 7,341
Median class complexity 7.0
Median method complexity 2.0
Most complex class WC_Payment_Gateway_WCPay
Most complex function WC_Payment_Gateway_WCPay::process_payment_for_order()
Classes 329
Methods 2,593
Functions 18

Additions

No data available.

PHP Error Log

The log file is empty.

See also: All tests for this plugin