Posts To Events 1.56

Does Posts To Events work with WordPress 6.5.5 and PHP 8.1.12? A smoke test was performed on .

Summary

Errors
The plugin could not be activated
1PHP fatal errors
1PHP deprecation warnings
No JavaScript exceptions
No resource errors
Performance

No data available.

Environment
WordPress version6.5.5
PHP version8.1.12
MySQL version10.6.10
PHP memory limit512M
Plugin Info
Last updated
Active installs 20+
WordPress.org page https://wordpress.org/plugins/posts-to-events/
Badges

WordPress compatibility badge PHP compatibility badge

Get badge code

Pages 1

Plugins ‹ Test site — WordPress

Page screenshot: Plugins ‹ Test site — WordPress
URL /wp-admin/plugins.php?plugin=posts-to-events%2Fposts_to_events.php
Requested URL /wp-admin/plugins.php?action=activate&plugin=posts-to-events%2Fposts_to_events.php&plugin_status=all&paged=1&s&_wpnonce=5eb08b4fc1
Aspect after-activation
HTTP status 200
Load time 0.246 s
Memory usage 3.38 MiB
JS errors None
Resource errors None

Benchmark

No benchmark data available.

Code Statistics

Note: Third-party libraries and minified JS/CSS files are excluded from these statistics where possible, so the numbers you see here may be lower than those reported by other tools.

PHP
Language % Lines of code Comment lines Files
PHP95.1%3101,2596
CSS4.9%1601
Total 326 1,259 7

PHP Code Analysis | More results »

Lines of code 2,676
Total complexity 650
Median class complexity 153.0
Median method complexity 5.0
Most complex class timthumb
Most complex function timthumb::processImageAndWriteToCache()
Classes 4
Methods 78
Functions 14

Additions

No data available.

PHP Error Log 10 lines

[10-Jul-2024 14:18:39 UTC] PHP Deprecated:  Optional parameter $post_id declared before required parameter $id is implicitly treated as a required parameter in /wp-content/plugins/posts-to-events/pte_admin.php on line 115
[10-Jul-2024 14:18:39 UTC] PHP Fatal error:  Uncaught Error: Call to undefined function create_function() in /wp-content/plugins/posts-to-events/widget.php:287
Stack trace:
#0 /wp-content/plugins/posts-to-events/pte_admin.php(7): require_once()
#1 /wp-content/plugins/posts-to-events/posts_to_events.php(31): require_once('...')
#2 /wp-admin/includes/plugin.php(2389): include_once('...')
#3 /wp-admin/includes/plugin.php(675): plugin_sandbox_scrape()
#4 /wp-admin/plugins.php(60): activate_plugin()
#5 {main}
  thrown in /wp-content/plugins/posts-to-events/widget.php on line 287
See also: All tests for this plugin