Get Satisfaction 0.1

Does Get Satisfaction work with WordPress 6.0.2 and PHP 7.4.8? A smoke test was performed on .

Summary

Errors
The plugin could not be activated
3PHP fatal errors
3PHP warnings
7PHP deprecation warnings
No JavaScript exceptions
No resource errors
Performance

No data available.

Environment
WordPress version6.0.2
PHP version7.4.8
MySQL version8.0.21
PHP memory limit256M
Plugin Info
Last updated
Active installs <10
WordPress.org page https://wordpress.org/plugins/get-satisfaction-for-wordpress/
Badges

WordPress compatibility badge PHP compatibility badge

Get badge code

Pages 1

Plugins ‹ Test site — WordPress

Page screenshot: Plugins ‹ Test site — WordPress
URL /wp-admin/plugins.php?plugin=get-satisfaction-for-wordpress%2Fgetsatisfaction.php
Requested URL /wp-admin/plugins.php?action=activate&plugin=get-satisfaction-for-wordpress%2Fgetsatisfaction.php&plugin_status=all&paged=1&s&_wpnonce=ea87706fa3
Aspect after-activation
HTTP status 200
Load time 0.316 s
Memory usage 3.69 MiB
JS errors None
Resource errors None

Benchmark

No benchmark data available.

Code Statistics

Note: Third-party libraries and minified JS/CSS files are excluded from these statistics where possible, so the numbers you see here may be lower than those reported by other tools.

PHP
Language % Lines of code Comment lines Files
PHP95.8%2,2991,02320
CSS4.2%10101
Total 2,400 1,023 21

PHP Code Analysis | More results »

Lines of code 2,212
Total complexity 539
Median class complexity 5.0
Median method complexity 2.0
Most complex class hKit
Most complex function hKit::processNodes()
Classes 17
Methods 108
Functions 67

Additions

No data available.

PHP Error Log 13 lines

[23-Sep-2022 02:47:04 UTC] PHP Deprecated:  Methods with the same name as their class will not be constructors in a future version of PHP; hKit has a deprecated constructor in /wp-content/plugins/get-satisfaction-for-wordpress/classes/hkit.class.php on line 60
[23-Sep-2022 02:47:04 UTC] PHP Deprecated:  Array and string offset access syntax with curly braces is deprecated in /wp-content/plugins/get-satisfaction-for-wordpress/classes/HTTP_Request_Oauth.php on line 9
[23-Sep-2022 02:47:04 UTC] PHP Deprecated:  Array and string offset access syntax with curly braces is deprecated in /wp-content/plugins/get-satisfaction-for-wordpress/classes/HTTP_Request_Oauth.php on line 9
[23-Sep-2022 02:47:04 UTC] PHP Deprecated:  Array and string offset access syntax with curly braces is deprecated in /wp-content/plugins/get-satisfaction-for-wordpress/classes/HTTP_Request_Oauth.php on line 195
[23-Sep-2022 02:47:04 UTC] PHP Deprecated:  Array and string offset access syntax with curly braces is deprecated in /wp-content/plugins/get-satisfaction-for-wordpress/classes/HTTP_Request_Oauth.php on line 195
[23-Sep-2022 02:47:04 UTC] PHP Deprecated:  Unparenthesized `a ? b : c ? d : e` is deprecated. Use either `(a ? b : c) ? d : e` or `a ? b : (c ? d : e)` in /wp-content/plugins/get-satisfaction-for-wordpress/classes/HTTP_Request_Oauth.php on line 259
[23-Sep-2022 02:47:04 UTC] PHP Deprecated:  Methods with the same name as their class will not be constructors in a future version of PHP; HTTP_Request_OAuth has a deprecated constructor in /wp-content/plugins/get-satisfaction-for-wordpress/classes/HTTP_Request_Oauth.php on line 15
[23-Sep-2022 02:47:04 UTC] PHP Warning:  require_once(HTTP/Request.php): failed to open stream: No such file or directory in /wp-content/plugins/get-satisfaction-for-wordpress/classes/HTTP_Request_Oauth.php on line 3
[23-Sep-2022 02:47:04 UTC] PHP Fatal error:  require_once(): Failed opening required 'HTTP/Request.php' (include_path='.:/opt/bitnami/php/lib/php') in /wp-content/plugins/get-satisfaction-for-wordpress/classes/HTTP_Request_Oauth.php on line 3
[23-Sep-2022 02:47:04 UTC] PHP Warning:  require_once(HTTP/Request.php): failed to open stream: No such file or directory in /wp-content/plugins/get-satisfaction-for-wordpress/classes/HTTP_Request_Oauth.php on line 3
[23-Sep-2022 02:47:04 UTC] PHP Fatal error:  require_once(): Failed opening required 'HTTP/Request.php' (include_path='.:/opt/bitnami/php/lib/php') in /wp-content/plugins/get-satisfaction-for-wordpress/classes/HTTP_Request_Oauth.php on line 3
[23-Sep-2022 02:47:05 UTC] PHP Warning:  require_once(HTTP/Request.php): failed to open stream: No such file or directory in /wp-content/plugins/get-satisfaction-for-wordpress/classes/HTTP_Request_Oauth.php on line 3
[23-Sep-2022 02:47:05 UTC] PHP Fatal error:  require_once(): Failed opening required 'HTTP/Request.php' (include_path='.:/opt/bitnami/php/lib/php') in /wp-content/plugins/get-satisfaction-for-wordpress/classes/HTTP_Request_Oauth.php on line 3
See also: All tests for this plugin