Asgaros Forum 1.6.7

Does Asgaros Forum work with WordPress 4.9.1 and PHP 7.0.16? A smoke test was performed on .

Summary

Errors
No PHP errors, warnings or notices
No JavaScript exceptions
All test pages loaded successfully
No resource errors
Looks good! No problems were detected.
Performance

Memory usage: 211.45 KiB
The average PHP memory usage increased by this amount after activating by the plugin.

Page speed impact: insignificant.
The plugin didn't make the site noticeably slower.

Environment
WordPress version4.9.1
PHP version7.0.16
MySQL version5.7.17
PHP memory limit256M
Plugin Info
Last updated
Active installs 20,000+
WordPress.org page https://wordpress.org/plugins/asgaros-forum/
Badges

WordPress compatibility badge PHP compatibility badge

Get badge code

Pages 6

Plugins ‹ Test site — WordPress

Page screenshot: Plugins ‹ Test site — WordPress
URL /wp-admin/plugins.php?activate=true&plugin_status=all&paged=1&s=
Requested URL /wp-admin/plugins.php?action=activate&plugin=asgaros-forum%2Fasgaros-forum.php&plugin_status=all&paged=1&s&_wpnonce=befe2e06d7
Aspect after-activation
HTTP status 200 OK
Load time 0.276 s
Memory usage 3.23 MiB
JS errors None
Resource errors None

Forum

Page screenshot: Forum
URL /wp-admin/admin.php?page=asgarosforum-options
Aspect menu-item
HTTP status 200 OK
Load time 0.075 s
Memory usage 3.32 MiB
JS errors None
Resource errors None

Forum → Structure

Page screenshot: Forum → Structure
URL /wp-admin/admin.php?page=asgarosforum-structure
Aspect menu-item
HTTP status 200 OK
Load time 0.053 s
Memory usage 3.24 MiB
JS errors None
Resource errors None

Forum → User Groups

Page screenshot: Forum → User Groups
URL /wp-admin/admin.php?page=asgarosforum-usergroups
Aspect menu-item
HTTP status 200 OK
Load time 0.145 s
Memory usage 3.21 MiB
JS errors None
Resource errors None

Test site – Just another WordPress site

Page screenshot: Test site – Just another WordPress site
URL /
Aspect front-page
HTTP status 200 OK
Load time 0.095 s
Memory usage 2.95 MiB
JS errors None
Resource errors None

Widgets ‹ Test site — WordPress

Page screenshot: Widgets ‹ Test site — WordPress
URL /wp-admin/widgets.php
Aspect new-sidebar-widgets
HTTP status 200 OK
Load time 0.121 s
Memory usage 3.17 MiB
JS errors None
Resource errors None

Benchmark

URL Load time Memory usage
Inactive Active Change Inactive Active Change
/wp-admin/index.php0.191 s0.057 s-0.134 s2.98 MiB3.22 MiB+ 254.08 KiB
/wp-admin/edit.php0.119 s0.128 s+0.009 s3 MiB3.25 MiB+ 257.2 KiB
/wp-admin/post-new.php0.216 s0.227 s+0.011 s3.07 MiB3.33 MiB+ 264.52 KiB
/wp-admin/upload.php0.111 s0.068 s-0.043 s2.9 MiB3.09 MiB+ 190.35 KiB
/wp-admin/options-writing.php0.111 s0.129 s+0.018 s2.99 MiB3.08 MiB+ 95.98 KiB
/wp-admin/media-new.php0.072 s0.095 s+0.023 s2.89 MiB3.07 MiB+ 189.79 KiB
/wp-admin/edit-tags.php?taxonomy=category0.110 s0.108 s-0.002 s2.93 MiB3.11 MiB+ 190.7 KiB
/wp-admin/post-new.php?post_type=page0.243 s0.071 s-0.172 s3.08 MiB3.33 MiB+ 257.26 KiB
/wp-admin/options-discussion.php0.114 s0.109 s-0.005 s2.89 MiB3.08 MiB+ 190.1 KiB
/wp-admin/edit-comments.php0.126 s0.138 s+0.012 s2.93 MiB3.12 MiB+ 189.64 KiB
/0.180 s0.149 s-0.031 s2.71 MiB2.95 MiB+ 246.4 KiB
Average 0.145 s0.116 s-0.029 s2.94 MiB3.15 MiB+ 211.45 KiB

Additions

Things that the plugin adds to the site. This section is not intended to be comprehensive. The test tool only looks for a few specific types of added content.

Database Tables 3

Options wp_options 4

Sidebar Widgets 2

ID Name
asgarosforumrecentposts_widgetAsgaros Forum: Recent Posts
asgarosforumrecenttopics_widgetAsgaros Forum: Recent Topics

PHP Error Log

The log file is empty.

See also: All tests for this plugin, How to Hide Asgaros Forum Admin Menus and Meta Boxes