Asgaros Forum 1.10.0

Does Asgaros Forum work with WordPress 4.9.8 and PHP 7.0.16? A smoke test was performed on .

Summary

Errors
No PHP errors, warnings or notices
No JavaScript exceptions
All test pages loaded successfully
No resource errors
Looks good! No problems were detected.
Performance

Memory usage: 269.03 KiB
The average PHP memory usage increased by this amount after activating by the plugin.

Page speed impact: insignificant.
The plugin didn't make the site noticeably slower.

Environment
WordPress version4.9.8
PHP version7.0.16
MySQL version5.7.17
PHP memory limit256M
Plugin Info
Last updated
Active installs 20,000+
WordPress.org page https://wordpress.org/plugins/asgaros-forum/
Badges

WordPress compatibility badge PHP compatibility badge

Get badge code

Pages 8

Plugins ‹ Test site — WordPress

Page screenshot: Plugins ‹ Test site — WordPress
URL /wp-admin/plugins.php?activate=true&plugin_status=all&paged=1&s=
Requested URL /wp-admin/plugins.php?action=activate&plugin=asgaros-forum%2Fasgaros-forum.php&plugin_status=all&paged=1&s&_wpnonce=5d3f3f219e
Aspect after-activation
HTTP status 200 OK
Load time 0.185 s
Memory usage 3.44 MiB
JS errors None
Resource errors None

Forum

Page screenshot: Forum
URL /wp-admin/admin.php?page=asgarosforum-structure
Aspect menu-item
HTTP status 200 OK
Load time 0.036 s
Memory usage 3.44 MiB
JS errors None
Resource errors None

Forum → Appearance

Page screenshot: Forum → Appearance
URL /wp-admin/admin.php?page=asgarosforum-appearance
Aspect menu-item
HTTP status 200 OK
Load time 0.040 s
Memory usage 3.39 MiB
JS errors None
Resource errors None

Forum → User Groups

Page screenshot: Forum → User Groups
URL /wp-admin/admin.php?page=asgarosforum-usergroups
Aspect menu-item
HTTP status 200 OK
Load time 0.048 s
Memory usage 3.4 MiB
JS errors None
Resource errors None

Forum → Reports

Page screenshot: Forum → Reports
URL /wp-admin/admin.php?page=asgarosforum-reports
Aspect menu-item
HTTP status 200 OK
Load time 0.034 s
Memory usage 3.37 MiB
JS errors None
Resource errors None

Forum → Settings

Page screenshot: Forum → Settings
URL /wp-admin/admin.php?page=asgarosforum-options
Aspect menu-item
HTTP status 200 OK
Load time 0.040 s
Memory usage 3.62 MiB
JS errors None
Resource errors None

Test site – Just another WordPress site

Page screenshot: Test site – Just another WordPress site
URL /
Aspect front-page
HTTP status 200 OK
Load time 0.094 s
Memory usage 3.05 MiB
JS errors None
Resource errors None

Widgets ‹ Test site — WordPress

Page screenshot: Widgets ‹ Test site — WordPress
URL /wp-admin/widgets.php
Aspect new-sidebar-widgets
HTTP status 200 OK
Load time 0.087 s
Memory usage 3.35 MiB
JS errors None
Resource errors None

Benchmark

URL Load time Memory usage
Inactive Active Change Inactive Active Change
/wp-admin/index.php0.130 s0.045 s-0.085 s3.12 MiB3.35 MiB+ 241.51 KiB
/wp-admin/edit.php0.096 s0.062 s-0.034 s3.14 MiB3.39 MiB+ 253.75 KiB
/wp-admin/post-new.php0.208 s0.072 s-0.136 s3.21 MiB3.45 MiB+ 251.96 KiB
/wp-admin/upload.php0.097 s0.041 s-0.056 s2.98 MiB3.28 MiB+ 305.78 KiB
/wp-admin/options-writing.php0.082 s0.044 s-0.038 s3.06 MiB3.27 MiB+ 214.01 KiB
/wp-admin/media-new.php0.047 s0.039 s-0.008 s2.96 MiB3.26 MiB+ 305.22 KiB
/wp-admin/edit-tags.php?taxonomy=category0.080 s0.033 s-0.047 s3 MiB3.3 MiB+ 306.13 KiB
/wp-admin/post-new.php?post_type=page0.142 s0.060 s-0.082 s3.21 MiB3.45 MiB+ 244.7 KiB
/wp-admin/options-discussion.php0.082 s0.069 s-0.013 s2.97 MiB3.26 MiB+ 305.53 KiB
/wp-admin/edit-comments.php0.081 s0.032 s-0.049 s3.01 MiB3.3 MiB+ 305.07 KiB
/0.091 s0.117 s+0.026 s2.83 MiB3.05 MiB+ 225.65 KiB
Average 0.103 s0.056 s-0.047 s3.04 MiB3.31 MiB+ 269.03 KiB

Additions

Things that the plugin adds to the site. This section is not intended to be comprehensive. The test tool only looks for a few specific types of added content.

Database Tables 5

Options wp_options 7

Sidebar Widgets 3

ID Name
asgarosforumrecentposts_widgetAsgaros Forum: Recent Posts
asgarosforumrecenttopics_widgetAsgaros Forum: Recent Topics
asgarosforumsearch_widgetAsgaros Forum: Search

PHP Error Log

The log file is empty.

See also: All tests for this plugin, How to Hide Asgaros Forum Admin Menus and Meta Boxes