WP JS 2.0.6

Does WP JS work with WordPress 5.2.4 and PHP 7.2.16? A smoke test was performed on .

Summary

Errors
2PHP fatal errors
1PHP warnings
6PHP notices
29WordPress deprecation warnings
No JavaScript exceptions
All test pages loaded successfully
No resource errors
Performance

Memory usage: -7.35 KiB
The average PHP memory usage increased by this amount after activating by the plugin.

Page speed impact: insignificant.
The plugin didn't make the site noticeably slower.

Environment
WordPress version5.2.4
PHP version7.2.16
MySQL version8.0.15
PHP memory limit256M
Plugin Info
Last updated
Active installs 100+
WordPress.org page https://wordpress.org/plugins/wp-js/
Badges

Get badge code

Pages 3

Plugins ‹ Test site — WordPress

Page screenshot: Plugins ‹ Test site — WordPress
URL /wp-admin/plugins.php?plugin_status=all&paged=1&s
Requested URL /wp-admin/plugins.php?action=activate&plugin=wp-js%2Fwp-js.php&plugin_status=all&paged=1&s&_wpnonce=2456339508
Aspect after-activation
HTTP status 200
Load time 0.352 s
Memory usage 3.49 MiB
JS errors None
Resource errors None

Settings → WP JS

Page screenshot: Settings → WP JS
URL /wp-admin/options-general.php?page=wp-js%2Fwp-js.php
Requested URL /wp-admin/options-general.php?page=wp-js/wp-js.php
Aspect menu-item
HTTP status 200
Load time 0.220 s
Memory usage 3.45 MiB
JS errors None
Resource errors None

Test site – Just another WordPress site

Page screenshot: Test site – Just another WordPress site
URL /
Aspect front-page
HTTP status 200
Load time 0.173 s
Memory usage 3.23 MiB
JS errors None
Resource errors None

Benchmark

URL Load time Memory usage
Inactive Active Change Inactive Active Change
/wp-admin/index.php0.252 s0.199 s-0.053 s3.6 MiB3.61 MiB+ 5.16 KiB
/wp-admin/edit.php0.210 s0.272 s+0.062 s3.63 MiB3.64 MiB+ 5.18 KiB
/wp-admin/post-new.php1.014 s0.373 s-0.641 s5.27 MiB
/wp-admin/upload.php0.464 s0.290 s-0.174 s3.46 MiB3.47 MiB+ 4.52 KiB
/wp-admin/options-writing.php0.168 s0.240 s+0.072 s3.55 MiB3.46 MiB- 88.52 KiB
/wp-admin/media-new.php0.187 s0.271 s+0.084 s3.45 MiB3.45 MiB+ 5.05 KiB
/wp-admin/edit-tags.php?taxonomy=category0.195 s0.267 s+0.072 s3.49 MiB3.54 MiB+ 60.49 KiB
/wp-admin/post-new.php?post_type=page0.902 s0.336 s-0.566 s5.25 MiB
/wp-admin/options-discussion.php0.596 s0.158 s-0.438 s3.45 MiB3.45 MiB+ 5.37 KiB
/wp-admin/edit-comments.php0.259 s0.298 s+0.039 s3.55 MiB3.56 MiB+ 4.27 KiB
/0.340 s0.317 s-0.023 s3.3 MiB3.24 MiB- 67.63 KiB
Average 0.417 s0.275 s-0.142 s3.82 MiB3.49 MiB- 7.35 KiB

Additions

Things that the plugin adds to the site. This section is not intended to be comprehensive. The test tool only looks for a few specific types of added content.

Options wp_options 4

PHP Error Log 56 lines

[23-Oct-2019 07:19:49 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[23-Oct-2019 07:19:49 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[23-Oct-2019 07:19:49 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[23-Oct-2019 07:19:49 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[23-Oct-2019 07:19:50 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[23-Oct-2019 07:19:50 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[23-Oct-2019 07:19:50 UTC] PHP Notice:  Undefined index: wp_js_clear_cache in /wp-content/plugins/wp-js/wp-js.php on line 107
[23-Oct-2019 07:19:50 UTC] PHP Notice:  Undefined index: wp_js_edit_expiry in /wp-content/plugins/wp-js/wp-js.php on line 115
[23-Oct-2019 07:19:50 UTC] PHP Notice:  Undefined index: wp_js_activation in /wp-content/plugins/wp-js/wp-js.php on line 119
[23-Oct-2019 07:19:50 UTC] PHP Notice:  Undefined index: wp_js_within_posts_activation in /wp-content/plugins/wp-js/wp-js.php on line 122
[23-Oct-2019 07:19:50 UTC] PHP Notice:  Undefined index: wp_js_edit_expiry in /wp-content/plugins/wp-js/wp-js-functions.php on line 176
[23-Oct-2019 07:19:50 UTC] PHP Notice:  Undefined index: wp_js_message in /wp-content/plugins/wp-js/wp-js.php on line 140
[23-Oct-2019 07:19:50 UTC] PHP Warning:  count(): Parameter must be an array or an object that implements Countable in /wp-content/plugins/wp-js/wp-js.php on line 80
[23-Oct-2019 07:19:51 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[23-Oct-2019 07:19:51 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[23-Oct-2019 07:19:51 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[23-Oct-2019 07:19:51 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[23-Oct-2019 07:19:51 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[23-Oct-2019 07:19:51 UTC] PHP Fatal error:  Uncaught Error: Call to undefined function eregi() in /wp-content/plugins/wp-js/wp-js-functions.php:133
Stack trace:
#0 /wp-content/plugins/wp-js/wp-js-files-list.php(284): wp_js_directory_map('/opt/bitnami/ap...', '.js$', false)
#1 /wp-content/plugins/wp-js/wp-js-files-list.php(218): wp_js_files(49, false)
#2 /wp-includes/class-wp-hook.php(286): wp_js_files_display(Object(WP_Post))
#3 /wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array)
#4 /wp-includes/plugin.php(465): WP_Hook->do_action(Array)
#5 /wp-admin/includes/post.php(2367): do_action('edit_form_advan...', Object(WP_Post))
#6 /wp-admin/includes/post.php(2236): the_block_editor_meta_box_post_form_hidden_fields(Object(WP_Post))
#7 /w in /wp-content/plugins/wp-js/wp-js-functions.php on line 133
[23-Oct-2019 07:19:52 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[23-Oct-2019 07:19:52 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[23-Oct-2019 07:19:52 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[23-Oct-2019 07:19:52 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[23-Oct-2019 07:19:52 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[23-Oct-2019 07:19:52 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[23-Oct-2019 07:19:52 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[23-Oct-2019 07:19:52 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[23-Oct-2019 07:19:53 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[23-Oct-2019 07:19:53 UTC] PHP Fatal error:  Uncaught Error: Call to undefined function eregi() in /wp-content/plugins/wp-js/wp-js-functions.php:133
Stack trace:
#0 /wp-content/plugins/wp-js/wp-js-files-list.php(284): wp_js_directory_map('/opt/bitnami/ap...', '.js$', false)
#1 /wp-content/plugins/wp-js/wp-js-files-list.php(218): wp_js_files(50, false)
#2 /wp-includes/class-wp-hook.php(286): wp_js_files_display(Object(WP_Post))
#3 /wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array)
#4 /wp-includes/plugin.php(465): WP_Hook->do_action(Array)
#5 /wp-admin/includes/post.php(2367): do_action('edit_form_advan...', Object(WP_Post))
#6 /wp-admin/includes/post.php(2236): the_block_editor_meta_box_post_form_hidden_fields(Object(WP_Post))
#7 /w in /wp-content/plugins/wp-js/wp-js-functions.php on line 133
[23-Oct-2019 07:19:53 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[23-Oct-2019 07:19:53 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[23-Oct-2019 07:19:53 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[23-Oct-2019 07:19:53 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[23-Oct-2019 07:19:54 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[23-Oct-2019 07:19:54 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[23-Oct-2019 07:19:54 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[23-Oct-2019 07:19:54 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[23-Oct-2019 07:19:54 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
See also: All tests for this plugin