Ultimate Google Analytics 1.6.0

Does Ultimate Google Analytics work with WordPress 5.2.3 and PHP 7.2.16? A smoke test was performed on .

Summary

Errors
45PHP warnings
2PHP notices
30WordPress deprecation warnings
No JavaScript exceptions
All test pages loaded successfully
No resource errors
Performance

Memory usage: -2.79 KiB
The average PHP memory usage increased by this amount after activating by the plugin.

Page speed impact: 0.061 seconds
The average page load time increased by this amount after activating the plugin.

Environment
WordPress version5.2.3
PHP version7.2.16
MySQL version8.0.15
PHP memory limit256M
Plugin Info
Last updated
Active installs 50,000+
WordPress.org page https://wordpress.org/plugins/ultimate-google-analytics/
Badges

Get badge code

Pages 3

Plugins ‹ Test site — WordPress

Page screenshot: Plugins ‹ Test site — WordPress
URL /wp-admin/plugins.php?plugin_status=all&paged=1&s
Requested URL /wp-admin/plugins.php?action=activate&plugin=ultimate-google-analytics%2Fultimate_ga.php&plugin_status=all&paged=1&s&_wpnonce=610ddf0891
Aspect after-activation
HTTP status 200
Load time 1.069 s
Memory usage 3.5 MiB
JS errors None
Resource errors None

Settings → Ultimate GA

Page screenshot: Settings → Ultimate GA
URL /wp-admin/options-general.php?page=ultimate_ga.php
Aspect menu-item
HTTP status 200
Load time 0.608 s
Memory usage 3.49 MiB
JS errors None
Resource errors None

Test site – Just another WordPress site

Page screenshot: Test site – Just another WordPress site
URL /
Aspect front-page
HTTP status 200
Load time 0.302 s
Memory usage 3.23 MiB
JS errors None
Resource errors None

Benchmark

URL Load time Memory usage
Inactive Active Change Inactive Active Change
/wp-admin/index.php0.297 s0.224 s-0.073 s3.6 MiB3.61 MiB+ 12.76 KiB
/wp-admin/edit.php0.252 s0.306 s+0.054 s3.63 MiB3.64 MiB+ 12 KiB
/wp-admin/post-new.php1.266 s1.214 s-0.052 s5.27 MiB5.29 MiB+ 19.84 KiB
/wp-admin/upload.php0.569 s1.185 s+0.616 s3.46 MiB3.47 MiB+ 11.1 KiB
/wp-admin/options-writing.php0.229 s0.268 s+0.039 s3.55 MiB3.47 MiB- 81.93 KiB
/wp-admin/media-new.php0.344 s0.307 s-0.037 s3.44 MiB3.46 MiB+ 11.64 KiB
/wp-admin/edit-tags.php?taxonomy=category0.233 s0.300 s+0.067 s3.49 MiB3.5 MiB+ 12.55 KiB
/wp-admin/post-new.php?post_type=page1.099 s1.255 s+0.156 s5.25 MiB5.27 MiB+ 13.05 KiB
/wp-admin/options-discussion.php0.664 s0.617 s-0.047 s3.45 MiB3.46 MiB+ 11.95 KiB
/wp-admin/edit-comments.php0.228 s0.232 s+0.004 s3.55 MiB3.56 MiB+ 10.88 KiB
/0.369 s0.310 s-0.059 s3.3 MiB3.24 MiB- 64.53 KiB
Average 0.505 s0.565 s+0.061 s3.82 MiB3.82 MiB- 2.79 KiB

Additions

Things that the plugin adds to the site. This section is not intended to be comprehensive. The test tool only looks for a few specific types of added content.

Options wp_options 1

PHP Error Log 77 lines

[05-Sep-2019 07:04:22 UTC] PHP Notice:  add_option was called with an argument that is <strong>deprecated</strong> since version 2.3.0 with no alternative available. in /wp-includes/functions.php on line 4655
[05-Sep-2019 07:04:22 UTC] PHP Notice:  Undefined variable: response in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 277
[05-Sep-2019 07:04:23 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:23 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4652
[05-Sep-2019 07:04:23 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4652
[05-Sep-2019 07:04:23 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:23 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4652
[05-Sep-2019 07:04:23 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4652
[05-Sep-2019 07:04:23 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:23 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:23 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4652
[05-Sep-2019 07:04:24 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4652
[05-Sep-2019 07:04:24 UTC] PHP Notice:  Undefined variable: response in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 277
[05-Sep-2019 07:04:24 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:24 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:24 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:24 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:24 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:24 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:25 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4652
[05-Sep-2019 07:04:25 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4652
[05-Sep-2019 07:04:25 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:25 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:25 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4652
[05-Sep-2019 07:04:25 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4652
[05-Sep-2019 07:04:25 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:26 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:26 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4652
[05-Sep-2019 07:04:26 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:26 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:26 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:26 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:27 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:27 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:27 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:27 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4652
[05-Sep-2019 07:04:27 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4652
[05-Sep-2019 07:04:27 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:28 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:28 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4652
[05-Sep-2019 07:04:28 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4652
[05-Sep-2019 07:04:28 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:28 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4652
[05-Sep-2019 07:04:28 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4652
[05-Sep-2019 07:04:28 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:29 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4652
[05-Sep-2019 07:04:29 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4652
[05-Sep-2019 07:04:29 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:29 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4652
[05-Sep-2019 07:04:29 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:29 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:29 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:29 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:30 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:30 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:30 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:30 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4652
[05-Sep-2019 07:04:30 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4652
[05-Sep-2019 07:04:30 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:31 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4652
[05-Sep-2019 07:04:31 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4652
[05-Sep-2019 07:04:31 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:31 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:31 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:31 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:31 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:31 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:31 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:31 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4652
[05-Sep-2019 07:04:31 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4652
[05-Sep-2019 07:04:32 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:32 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:32 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4652
[05-Sep-2019 07:04:32 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4652
[05-Sep-2019 07:04:32 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
[05-Sep-2019 07:04:32 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4652
[05-Sep-2019 07:04:32 UTC] PHP Warning:  Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
See also: All tests for this plugin, How to Hide the "Ultimate GA" Admin Menu