TreeMagic-Cypress 3.0.1

Does TreeMagic-Cypress work with WordPress 4.9.4 and PHP 7.0.16? A smoke test was performed on .

Summary

Errors
4PHP notices
1PHP deprecation warnings
31WordPress deprecation warnings
No JavaScript exceptions
All test pages loaded successfully
No resource errors
Performance

Memory usage: 7.54 KiB
The average PHP memory usage increased by this amount after activating by the plugin.

Page speed impact: insignificant.
The plugin didn't make the site noticeably slower.

Environment
WordPress version4.9.4
PHP version7.0.16
MySQL version5.7.17
PHP memory limit256M
Plugin Info
Last updated
Active installs <10
WordPress.org page https://wordpress.org/plugins/treemagic-cypress/
Badges

Get badge code

Pages 3

Plugins ‹ Test site — WordPress

Page screenshot: Plugins ‹ Test site — WordPress
URL /wp-admin/plugins.php?activate=true&plugin_status=all&paged=1&s=
Requested URL /wp-admin/plugins.php?action=activate&plugin=treemagic-cypress%2FTM-Cypress.php&plugin_status=all&paged=1&s&_wpnonce=b018a23302
Aspect after-activation
HTTP status 200 OK
Load time 0.096 s
Memory usage 2.92 MiB
JS errors None
Resource errors None

Settings → TM-Cypress Options Editor

Page screenshot: Settings → TM-Cypress Options Editor
URL /wp-admin/options-general.php?page=TM-Cypress.php
Aspect menu-item
HTTP status 200 OK
Load time 0.059 s
Memory usage 2.89 MiB
JS errors None
Resource errors None

Test site – Just another WordPress site

Page screenshot: Test site – Just another WordPress site
URL /
Aspect front-page
HTTP status 200 OK
Load time 0.064 s
Memory usage 2.71 MiB
JS errors None
Resource errors None

Benchmark

URL Load time Memory usage
Inactive Active Change Inactive Active Change
/wp-admin/index.php0.118 s0.085 s-0.033 s2.97 MiB2.98 MiB+ 6.77 KiB
/wp-admin/edit.php0.100 s0.080 s-0.020 s3 MiB3.01 MiB+ 6.74 KiB
/wp-admin/post-new.php0.153 s0.151 s-0.002 s3.07 MiB3.08 MiB+ 13.91 KiB
/wp-admin/upload.php0.098 s0.101 s+0.003 s2.9 MiB2.91 MiB+ 7.26 KiB
/wp-admin/options-writing.php0.069 s0.068 s-0.001 s2.89 MiB2.9 MiB+ 7.26 KiB
/wp-admin/media-new.php0.038 s0.059 s+0.021 s2.88 MiB2.89 MiB+ 7.26 KiB
/wp-admin/edit-tags.php?taxonomy=category0.070 s0.071 s+0.001 s2.92 MiB2.93 MiB+ 7.26 KiB
/wp-admin/post-new.php?post_type=page0.144 s0.139 s-0.005 s3.07 MiB3.08 MiB+ 6.66 KiB
/wp-admin/options-discussion.php0.075 s0.074 s-0.001 s2.89 MiB2.89 MiB+ 7.26 KiB
/wp-admin/edit-comments.php0.070 s0.097 s+0.027 s2.93 MiB2.93 MiB+ 6.66 KiB
/0.065 s0.047 s-0.018 s2.7 MiB2.71 MiB+ 5.89 KiB
Average 0.091 s0.088 s-0.003 s2.93 MiB2.94 MiB+ 7.54 KiB

Additions

Things that the plugin adds to the site. This section is not intended to be comprehensive. The test tool only looks for a few specific types of added content.

Options wp_options 1

PHP Error Log 36 lines

[13-Feb-2018 14:07:11 UTC] PHP Deprecated:  Methods with the same name as their class will not be constructors in a future version of PHP; MQFunctions has a deprecated constructor in /wp-content/plugins/treemagic-cypress/TM-Cypress.php on line 11
[13-Feb-2018 14:07:11 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4031
[13-Feb-2018 14:07:11 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4031
[13-Feb-2018 14:07:11 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4031
[13-Feb-2018 14:07:11 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4031
[13-Feb-2018 14:07:11 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4031
[13-Feb-2018 14:07:11 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4031
[13-Feb-2018 14:07:11 UTC] PHP Notice:  Undefined offset: 3 in /wp-content/plugins/treemagic-cypress/TM-Cypress.php on line 272
[13-Feb-2018 14:07:11 UTC] PHP Notice:  Undefined offset: 3 in /wp-content/plugins/treemagic-cypress/TM-Cypress.php on line 291
[13-Feb-2018 14:07:11 UTC] PHP Notice:  Undefined offset: 3 in /wp-content/plugins/treemagic-cypress/TM-Cypress.php on line 48
[13-Feb-2018 14:07:12 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4031
[13-Feb-2018 14:07:12 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4031
[13-Feb-2018 14:07:12 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4031
[13-Feb-2018 14:07:12 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4031
[13-Feb-2018 14:07:12 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4031
[13-Feb-2018 14:07:12 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4031
[13-Feb-2018 14:07:13 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4031
[13-Feb-2018 14:07:13 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4031
[13-Feb-2018 14:07:13 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4031
[13-Feb-2018 14:07:13 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4031
[13-Feb-2018 14:07:13 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4031
[13-Feb-2018 14:07:13 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4031
[13-Feb-2018 14:07:13 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4031
[13-Feb-2018 14:07:13 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4031
[13-Feb-2018 14:07:13 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4031
[13-Feb-2018 14:07:13 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4031
[13-Feb-2018 14:07:14 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4031
[13-Feb-2018 14:07:14 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4031
[13-Feb-2018 14:07:14 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4031
[13-Feb-2018 14:07:14 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4031
[13-Feb-2018 14:07:14 UTC] PHP Notice:  Undefined offset: 3 in /wp-content/plugins/treemagic-cypress/TM-Cypress.php on line 48
[13-Feb-2018 14:07:14 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4031
[13-Feb-2018 14:07:14 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4031
[13-Feb-2018 14:07:14 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4031
[13-Feb-2018 14:07:14 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4031
[13-Feb-2018 14:07:15 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4031