Suggest Comments 0.8

Does Suggest Comments work with WordPress 5.2.4 and PHP 7.2.16? A smoke test was performed on .

Summary

Errors
1PHP notices
48WordPress deprecation warnings
No JavaScript exceptions
All test pages loaded successfully
No resource errors
Performance

Memory usage: 44.4 KiB
The average PHP memory usage increased by this amount after activating by the plugin.

Page speed impact: 0.038 seconds
The average page load time increased by this amount after activating the plugin.

Environment
WordPress version5.2.4
PHP version7.2.16
MySQL version8.0.15
PHP memory limit256M
Plugin Info
Last updated
Active installs <10
WordPress.org page https://wordpress.org/plugins/suggest-comments/
Badges

Get badge code

Pages 3

Plugins ‹ Test site — WordPress

Page screenshot: Plugins ‹ Test site — WordPress
URL /wp-admin/plugins.php?plugin_status=all&paged=1&s
Requested URL /wp-admin/plugins.php?action=activate&plugin=suggest-comments%2Fsuggestcomments.php&plugin_status=all&paged=1&s&_wpnonce=b9ae6cd2f5
Aspect after-activation
HTTP status 200
Load time 1.071 s
Memory usage 3.56 MiB
JS errors None
Resource errors None

Settings → Suggest Comments

Page screenshot: Settings → Suggest Comments
URL /wp-admin/options-general.php?page=suggestcomments.php
Aspect menu-item
HTTP status 200
Load time 0.273 s
Memory usage 3.46 MiB
JS errors None
Resource errors None

Test site – Just another WordPress site

Page screenshot: Test site – Just another WordPress site
URL /
Aspect front-page
HTTP status 200
Load time 0.201 s
Memory usage 3.54 MiB
JS errors None
Resource errors None

Benchmark

URL Load time Memory usage
Inactive Active Change Inactive Active Change
/wp-admin/index.php0.348 s0.250 s-0.098 s3.6 MiB3.61 MiB+ 13.63 KiB
/wp-admin/edit.php0.271 s0.357 s+0.086 s3.63 MiB3.64 MiB+ 13.63 KiB
/wp-admin/post-new.php1.346 s1.329 s-0.017 s5.27 MiB5.35 MiB+ 85.85 KiB
/wp-admin/upload.php0.754 s0.831 s+0.077 s3.46 MiB3.48 MiB+ 14.42 KiB
/wp-admin/options-writing.php0.197 s0.313 s+0.116 s3.55 MiB3.47 MiB- 80.3 KiB
/wp-admin/media-new.php0.242 s0.319 s+0.077 s3.45 MiB3.46 MiB+ 13.43 KiB
/wp-admin/edit-tags.php?taxonomy=category0.255 s0.317 s+0.062 s3.49 MiB3.56 MiB+ 78.18 KiB
/wp-admin/post-new.php?post_type=page1.336 s1.405 s+0.069 s5.25 MiB5.33 MiB+ 79.06 KiB
/wp-admin/options-discussion.php0.659 s0.660 s+0.001 s3.45 MiB3.46 MiB+ 13.59 KiB
/wp-admin/edit-comments.php0.243 s0.345 s+0.102 s3.55 MiB3.57 MiB+ 12.48 KiB
/0.382 s0.323 s-0.059 s3.3 MiB3.54 MiB+ 244.39 KiB
Average 0.548 s0.586 s+0.038 s3.82 MiB3.86 MiB+ 44.4 KiB

Additions

Things that the plugin adds to the site. This section is not intended to be comprehensive. The test tool only looks for a few specific types of added content.

Database Tables 1

Options wp_options 7

PHP Error Log 49 lines

[28-Oct-2019 16:37:21 UTC] PHP Notice:  Undefined variable: wp_version in /wp-content/plugins/suggest-comments/suggestcomments.php on line 27
[28-Oct-2019 16:37:21 UTC] PHP Notice:  upgrade-functions.php is <strong>deprecated</strong> since version 2.5.0! Use wp-admin/includes/upgrade.php instead. in /wp-includes/functions.php on line 4594
[28-Oct-2019 16:37:21 UTC] PHP Notice:  add_option was called with an argument that is <strong>deprecated</strong> since version 2.3.0 with no alternative available. in /wp-includes/functions.php on line 4660
[28-Oct-2019 16:37:21 UTC] PHP Notice:  wpdb::escape is <strong>deprecated</strong> since version 3.6.0! Use wpdb::prepare() or esc_sql() instead. in /wp-includes/functions.php on line 4440
[28-Oct-2019 16:37:21 UTC] PHP Notice:  add_option was called with an argument that is <strong>deprecated</strong> since version 2.3.0 with no alternative available. in /wp-includes/functions.php on line 4660
[28-Oct-2019 16:37:21 UTC] PHP Notice:  wpdb::escape is <strong>deprecated</strong> since version 3.6.0! Use wpdb::prepare() or esc_sql() instead. in /wp-includes/functions.php on line 4440
[28-Oct-2019 16:37:21 UTC] PHP Notice:  add_option was called with an argument that is <strong>deprecated</strong> since version 2.3.0 with no alternative available. in /wp-includes/functions.php on line 4660
[28-Oct-2019 16:37:21 UTC] PHP Notice:  wpdb::escape is <strong>deprecated</strong> since version 3.6.0! Use wpdb::prepare() or esc_sql() instead. in /wp-includes/functions.php on line 4440
[28-Oct-2019 16:37:21 UTC] PHP Notice:  add_option was called with an argument that is <strong>deprecated</strong> since version 2.3.0 with no alternative available. in /wp-includes/functions.php on line 4660
[28-Oct-2019 16:37:21 UTC] PHP Notice:  wpdb::escape is <strong>deprecated</strong> since version 3.6.0! Use wpdb::prepare() or esc_sql() instead. in /wp-includes/functions.php on line 4440
[28-Oct-2019 16:37:21 UTC] PHP Notice:  add_option was called with an argument that is <strong>deprecated</strong> since version 2.3.0 with no alternative available. in /wp-includes/functions.php on line 4660
[28-Oct-2019 16:37:21 UTC] PHP Notice:  wpdb::escape is <strong>deprecated</strong> since version 3.6.0! Use wpdb::prepare() or esc_sql() instead. in /wp-includes/functions.php on line 4440
[28-Oct-2019 16:37:21 UTC] PHP Notice:  add_option was called with an argument that is <strong>deprecated</strong> since version 2.3.0 with no alternative available. in /wp-includes/functions.php on line 4660
[28-Oct-2019 16:37:21 UTC] PHP Notice:  wpdb::escape is <strong>deprecated</strong> since version 3.6.0! Use wpdb::prepare() or esc_sql() instead. in /wp-includes/functions.php on line 4440
[28-Oct-2019 16:37:21 UTC] PHP Notice:  add_option was called with an argument that is <strong>deprecated</strong> since version 2.3.0 with no alternative available. in /wp-includes/functions.php on line 4660
[28-Oct-2019 16:37:21 UTC] PHP Notice:  wpdb::escape is <strong>deprecated</strong> since version 3.6.0! Use wpdb::prepare() or esc_sql() instead. in /wp-includes/functions.php on line 4440
[28-Oct-2019 16:37:21 UTC] PHP Notice:  wpdb::escape is <strong>deprecated</strong> since version 3.6.0! Use wpdb::prepare() or esc_sql() instead. in /wp-includes/functions.php on line 4440
[28-Oct-2019 16:37:21 UTC] PHP Notice:  wpdb::escape is <strong>deprecated</strong> since version 3.6.0! Use wpdb::prepare() or esc_sql() instead. in /wp-includes/functions.php on line 4440
[28-Oct-2019 16:37:21 UTC] PHP Notice:  wpdb::escape is <strong>deprecated</strong> since version 3.6.0! Use wpdb::prepare() or esc_sql() instead. in /wp-includes/functions.php on line 4440
[28-Oct-2019 16:37:21 UTC] PHP Notice:  wpdb::escape is <strong>deprecated</strong> since version 3.6.0! Use wpdb::prepare() or esc_sql() instead. in /wp-includes/functions.php on line 4440
[28-Oct-2019 16:37:21 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[28-Oct-2019 16:37:21 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[28-Oct-2019 16:37:22 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[28-Oct-2019 16:37:22 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[28-Oct-2019 16:37:22 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[28-Oct-2019 16:37:22 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[28-Oct-2019 16:37:23 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[28-Oct-2019 16:37:23 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[28-Oct-2019 16:37:24 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[28-Oct-2019 16:37:24 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[28-Oct-2019 16:37:24 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[28-Oct-2019 16:37:25 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[28-Oct-2019 16:37:25 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[28-Oct-2019 16:37:26 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[28-Oct-2019 16:37:26 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[28-Oct-2019 16:37:27 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[28-Oct-2019 16:37:27 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[28-Oct-2019 16:37:27 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[28-Oct-2019 16:37:27 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[28-Oct-2019 16:37:27 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[28-Oct-2019 16:37:29 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[28-Oct-2019 16:37:29 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[28-Oct-2019 16:37:29 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[28-Oct-2019 16:37:29 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[28-Oct-2019 16:37:30 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[28-Oct-2019 16:37:30 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[28-Oct-2019 16:37:30 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[28-Oct-2019 16:37:30 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
[28-Oct-2019 16:37:31 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0.0! Usage of user levels is deprecated. Use capabilities instead. in /wp-includes/functions.php on line 4657
See also: All tests for this plugin, How to Hide the "Suggest Comments" Admin Menu